WinMyDNS首页

WinMyDNS帮助文档

欢迎使用WinMyDNS双线智能DNS解析系统!

介绍

WinMyDNS - 双线智能DNS解析系统

WinMyDNS为用户提供一套基于Windows平台ACCESS/MSSQL数据库的DNS解析系统。本文档为WinMyDNS的安装、使用、及二次开发帮助文档。最新版本及更详细的介绍请参考www.winmydns.com网站。

双线智能DNS解析
国内唯一一款基于Windows平台上的双线智能DNS解析系统。 通过WinMyDNS用户可以方便地进行双线智能DNS解析及智能URL转发。

宕机检测
可以对加入到宕机检测列中的机器进行宕机检测。当发现服务器不通时，则自动将DNS解析向另一台机器。以保证你的客户随时都能访问到正常的服务器。

负载均衡
可以对加入到负载均衡的机器设置权重。系统自动根据权重比例来分析访问比例。

二次开发
与传统的文件型DNS系统不同。WinMyDNS把配置信息完全保存在ACCESS/MSSQL数据库中。用户进行二次开发时，只要对ACCESS/MSSQL数据库的记录添加、删除、修改就可以方便地完成二开发。

绿色免安装
本软件不需特别的安装及卸载。只要运行目录下的“安装服务.bat"及“卸载服务.bat"即可安装及卸载WinMyDNS服务。

WEB管理
本软件配置了WEB管理系统，可以通过WEB方式对WinMyDNS的所有功能进行管理。

IP分配表自由定义
本软件可以通过WEB管理方便自由定义DNS解析策略。可以定义网络组，并定义分组下面的IP分配表。

完善的移植工具
本软件自带的移植功能,可以方便地把通用的文本DNS文件移植进本系统。windows自带的DNS服务可以无缝地移植进本系统。

自动备份
本软件每天晚上4点自动对WinMyDNS所使用的数据库进行备份，并保存在backup目录下。把有效地降低系统故障的风险。

收费模式
本软件可以免费使用，免费版支持1000条DNS解析记录、DNS解析不会动态刷新、只不支持宕机检测、只支持一个月试用，一个月后WinMyDNS将不再提供DNS解析服务。正式版按DNS解析记录的数量收费，具体价格参考www.winmydns.com。


WinMyDNS概述

软件安装

获取代码

  1. 请从我们网站www.winmydns.com的下载中心下载免费软件；
  2. WinMyDNSAdmin.exe是管理配置程序；WinMyDNS.exe是服务程序;WinMyDNS.xml是配置文件。
  3. 安装服务.bat、卸载服务.bat、启动服务.bat、停止服务.bat批处理的管理脚本。
  4. DB目录是数据库目录，WinMyDNS.mdb是ACCESS数据库；winmydns.bak是MSSQL数据库备份，还原进MSSQL即可使用。
  5. WEB目录是WEB管理系统。
  6. IPtable目录是默认的IP分配表。请及时更新，该分配表的准确与否直接关系对客户来源智能判断的准确与否。最新的IP分配表请与我们联系。
  7. LOG是日志目录。

软件环境

  1. WINDOWS平台，主要为Windows2000、Windows2003、WindowsXP；
  2. Microsoft .NET Framework SDK v1.1 或Microsoft .NET Framework SDK v2.0，Windows2003已自带了，Windows2000需要另外安装。
  3. 希望DNS数据保存在MSSQL数据库里，需要安装MSSQL SERVER 2000。保存在ACCESS数据库的不需要。
  4. DNS区域名一万以上的，建议DNS数据配置在MSSQL中，以提高性能。

硬件环境

  1. DNS区域名五万以下的，普通配置，或可与其它服务共用一台服务器。
  2. DNS区域名五万以上的，请单独配置P4 CPU，1G以上内存的机器。

安装使用

  1. 运行"安装服务.bat"安装WinMyDNS服务。
  2. 恢复数据库。
    • 如果使用ACCESS数据库的跳过该步。
    • 如果使用MSSQL数据库的，请把"DB/WinMyDNS.BAK"的MSSQL数据库备份文件恢复到MSSQL中，以创建WinMyDNS数库。
  3. 运行WinMyDNSAdmin.exe程序，选持"数据库设置"页，设置数据库类型。
    • 使用ACCESS数据库的,在ACCESS数据库文件中填写:DB/WinMyDNS.mdb；
    • 使用MSSQL数据库的,请配置MSSQL的链接参数。
    • 启动WinMyDNS服务。
  4. 配置WEB管理程序。
    • 修改conn.asp中的数据库链接参数。
      'WinMyDNS数据库链接参数,请在这里手工修改
'##############################################################################################
WinMyDNSDbType="0"				'数据为类型,0:Access,1:mssql数据库
WInMyDNSAccessFile="../DB/WinMyDNS.MDB"	'Access数据库文件名
WinMyDNSDbIP = "localhost"			'WINIIS_Server 数据库IP地址
WinMyDNSDbName="WinMyDNS"			'WINIIS_Server 数据库名
WinMyDNSDbUser="sa"			'WINIIS_Server 数据库用户名
WinMyDNSDbPass="linyang"			'WINIIS_Server 数据库密码
WinMyDNSURL="url.winmydns.com"		'winmydns URL转发服务器的域名
'##############################################################################################

    • 在IIS管理器是创建一个网站或虚拟目录指向WEB目录。然后访问index.asp页面,默认是用户名:admin,密码123456
    • 登录进去之后,可以进行DNS解析管理。
  5. URL转发服务器设置（不需要URL转发功能不可以不用设置)。
    • 找一台服务器做为URL转发服务器。并且把IIS的默认站点（主机头为空的那个站点）的主目录指向到URL目录，并把index.asp设置为默认首页。
    • 修改URL/index.asp中的数据库链接参数。与上一步WEB/CONN.asp相同。
      注意正确填写 WinMyDNSURL参数，如:url.abc.com。并把解析一条url.abc.com的A记录指向到URL转发服务器。


WEB管理

WEB管理的使用

  1. 打开WEB管理站点出现登录框，默认用户名是admin，密码是123456，(登录后会员管理中可以修改admin的密码)。 输入用户名及密码即可登录。 如下图:

  2. 登录WEB管理界面之后，可以看到的管理功能有DNS管理、网络组管理、IP表管理。如下图：

    可以添加、删除、修改DNS区域，点后面的“解析”就可以进入DNS解析界面，如下图：

    与普通的DNS服务器不同。WinMyDNS支持智能解析。同样的www主机头，可以设置两条不同的解析。一个默认的解析，一条电信解析，或其它的。

    电信解析是指电信上网的客户访问www.fasdfa.com网站时，指向IP为192.168.1.1的服务器，默认解析是指非电信的所有客户访问网站时，都指向到192.168.1.2的服务器。同样还可以再增加网通的解析等。
    在这里还可做URL智能转发，注意添加URL转发之后，要添加一条CNAME的记录指向到URL转发服务器。如下图:

  3. 点击网络组管理，可以管理网络组，通过网络的定义，来把不同的上网方式的浏览都分类。分成网通、电信、铁通或国内、国外，或者本省、外省等不同的组别。如下图：

  4. 点击“IP分配表”可以定义各个组别的客户的IP分配情况。如下图:

    可以逐条删除IP分配记录，也可以批量删除一整组的所有IP分配记录。

    点“添加IP分配记录”可以添加IP分配，如下图：

    可以逐条添加，也可以批量添加。批量添加可以直接把iptable目录下的“网通IP.txt"或"电信ip.txt"的内容复制进来，批量添加。

    如果你找不到最新的IP分配表请与我们联系。

  5. 点击负载均衡，即可往winmydns系统里添加需要负载均衡的服务器,端口(TCP端口)及权重列表。如下图：


解析前的准备

注册DNS服务器

搭建自已的DNS服务器之后，为了使自已的DNS服务器在互联网上能够生效，先要为自已DNS服务器在互联网上进行注册。如注册ns1.rootmail.cn及ns2.rootmail.cn两个DNS服务器，分别使向自已的DNS服务器的IP。在注册生效之后，即可把所有需要用自已的DNS服务器解析的域名的DNS服务器改成ns1.rootmail.cn及ns2.rootmail.cn。

域名注册商控制面板一般有一个功能叫“注册本域名下的DNS”，点击该功能可以进行DNS服务器的注册。如果域名注册商的控制面板中没有该项功能，表示该注册不支持DNS服务器自助管理，需要与注册商的客服联系，注册DNS事宜。

下面以注册ns1.rootmail.cn及ns2.rootmail.cn两个DNS服务器为例，详细讲述DNS服务器的注册。

  1. 假如rootmail.cn域名是在新网注册的，要到新网的rootmail.cn的域名控制面板中进行ns1.rootmail.cn及ns2.rootmail.cn。同理如果rootmail.cn域名是在新网互联，或万网等其它注册商注册的，则要到新网互联或万网的控制面板中注册DNS。登录新网的rootmail.cn域名控制面板，可以看到如下图的按扭:

  2. 点击"注册本域名下的DNS"按扭,即可开始DNS注册。如下图：

    DNS名字填"ns1", IP地址填写您实际的WinMyDNS服务器的IP地址。

  3. 点确定按扭,即可完成DNS域名服务器注册。如下图：

      如果看到以上提示,说明主DNS服务器注册成功。

  4. 继续注册辅DNS服务器,如ns2.rootmail.cn。:

    步骤与注册ns1.roomail.cn类似

    再点击"注册本域名的DNS"即可开始ns2.rootmail.cn的注册

    主辅DNS都注册成功后,击点控制面板上的"修改本域名下面的DNS",可以看到你注册的DNS列表,如下图.点击进去即可修改：

  5. 进入新网域名的"MyDNS管理",添加NS1及NS2的A记录,分别指向你的主辅WinMyDNS的IP,如下图(注意,该解析一定要做,否则DNS服务器不会生效)。如下图：

  6. 进入WinMyDNS的WEB管理中创建rootmail.cn域名，并添加NS1及NS2的A记录,分别指向你的主辅WinMyDNS的IP(注意一定要指向到winmydns的IP地址)。如下图(注意,该解析一定要做,否则DNS服务器不会生效)。如下图：

      添加一个rootmail.cn域名之后，再在rootmail.cn域名下，添加ns1及ns2的A记录解析，注意一定要指向到winmydns的IP地址，否则解析不会生效。

  7. 查询DNS服务器注册是否成功及指向的IP是否正确。

    如果是.cn域名可以到:http://www.cnnic.cn/index/0A/index.htm查询,如下图:

    如果是.com的域名可以到http://www.internic.com/whois.html查询,如下图:

  8. DNS服务器注册成功之后，需要使用自已WinMyDNS解析的域名，要把其DNS服务器改成自已注册的ns1.rootmail.cn及ns2.rootmail.cn。任意域名的DNS服务器均可修改成自已注册的ns1.rootmail.cn及ns2.rootmail.cn，包括rootmail.cn这个域名本身的DNS也可以修改成ns1.rootmail.cn及ns2.rootmail.cn。以修改rootmail.cn的DNS为例，假设rootmail.cn的域名在新网注册，则进入新网的rootmail.cn域名控制面板，进行DNS服务器修改，如下图(注意：建议用测试的域名先测试正常后，再修改正式使用域名的DNS，该项操作会造成域名解析短暂中断，请谨慎操作）：


创建域名

创建域名

  1. 点击功能菜单“DNS管理”菜单。 如下图:

  2. 在DNS区域管理最下面一行，可以添加新域名。如下图：

    例如输入winmydns.com之后，点“添加”按钮即可以添加一个winmydns.com的域名，如下图：

    DNS区域名管理显示一条winmydns.com的记录，表示winmydns的域名添加成。

    进一点击上图中的“解析”的链接，即可进入winmydns.com的域名解析界面，如下图：

    在该界面中可以进行域名A，CNAME，MX，NS，TXT，IPV6，反向解析，URL转发，智能解析等解析操作。具体的解析操作请查看相关解析的说明章节。


A记录解析

A记录解析

  1. 点击功能菜单“DNS管理”菜单，找到您想要解析的域名，比如winmydns.com，点击该记录后面的“解析”链接，进入域名解析界面。 如下图:

  2. 在DNS解析表格的最下面一行，输入您想要解析的主机，如www；然后选择解析类型A，参数值中填入IP地址，点确定即可添加A记录。如下图：

    主机名：输入不带域名本身的主机名，比如要解析www.winmydns.com，只要输入www即可；如果解析winmydns.com，主机名这里为空即可。

    类 型： 选择A记录。

    参数值：填写您想要解析的IP地址。

    优先级：对于A记录，优先级参数没有用，按默认的10即可。

    TTL ：解析缓存时间，以秒为单位。默认600表示该条记录将缓存的时候为10分钟，即你下次修改该记录，要过10分钟才能生效。TTL也不宜填写太小，如果填写太小，会导致IE访问该域名总要先做DNS解析，影响访问速度。一般对于动态域名解析的应用建议TTL设置在120至300之间，对于普通的应用建议设置成600至3600之间。

    解析组：智能解析标志组，详见智能解析章节的说明。普通解析选择默认的“默认解析”即可。

  3. 上图点击“增加”按钮即可添加A记录。DNS解析中多一条www的解析，www.winmydns.com解析到192.168.1.1添加成功，如下图。

    点击上图中的“修改”按钮，可以直接修改该域名的解析IP地址，如下图：

    修改IP地址之后，点该记录后面的“提交”按钮，即可修改www.winiis.com的IP地址为192.168.1.2。


CNAME记录解析

CNAME记录解析

  1. 点击功能菜单“DNS管理”菜单，找到您想要解析的域名，比如winmydns.com，点击该记录后面的“解析”链接，进入域名解析界面。 如下图:

  2. 在DNS解析表格的最下面一行，输入您想要解析的主机，如www；然后选择解析类型CNAME，参数值中填入别名指向的域名，如www.abc.com，点确定即可添加CNAME记录。如下图：

    主机名：输入不带域名本身的主机名，比如要解析www.winmydns.com，只要输入www即可；如果解析winmydns.com，主机名这里为空即可。

    类 型： 选择CNAME记录。

    参数值：填写您想要指向的别名，如www.abc.com；注意不能填写IP地址。如果要使该解析生效，必须确认 www.abc.com 已经正确做了A记录解析且能够生效。

    优先级：对于CNAME记录，优先级参数没有用，按默认的10即可。

    TTL ：解析缓存时间，以秒为单位。默认600表示该条记录将缓存的时候为10分钟，即你下次修改该记录，要过10分钟才能生效。TTL也不宜填写太小，如果填写太小，会导致IE访问该域名总要先做DNS解析，影响访问速度。一般对于动态域名解析的应用建议TTL设置在120至300之间，对于普通的应用建议设置成600至3600之间。

    解析组：智能解析标志，详见智能解析章节的说明。普通解析选择默认的“默认解析”即可。

  3. 上图点击“增加”按钮即可添加CNAME记录。DNS解析中多一条www的解析，www.winmydns.com别名解析到www.abc.com表示别名添加成功，如下图。

    点击上图中的“修改”按钮，可以直接修改该域名的别名指向的地址，如改成www.123.com，如下图：

    修改别名地址之后，点该记录后面的“提交”按钮，即可修改www.winiis.com的别名为www.123.com。


MX记录解析

MX记录解析

  1. 点击功能菜单“DNS管理”菜单，找到您想要解析的域名，比如winmydns.com，点击该记录后面的“解析”链接，进入域名解析界面。 如下图:

  2. 在DNS解析表格的最下面一行，输入您想要解析的主机，一般为空，表示添加winmydns.com的MX记录；然后选择解析类型MX，参数值中填入MX指向的域名，如mail.winmydns.com，点确定即可添加MX记录。如下图：

    主机名：一般为空，比如要解析winmydns.com的MX记录，对应于 web@winmydns.com 有效；如果解析abc.winmydns.com，主机名这里填写abc，注意如果填写abc，表示你的邮箱格式是 web@abc.winmydns.com 的二级邮箱。

    类 型： 选择MX记录。

    参数值：一般填写mail.winmydns.com，注意不能直接写IP地址；如果要使该解析生效，MX记录做完了，还必须做一条mail.winmydns的A记录解析，指到邮件服务器的IP地址。

    优先级：一般按默认的10即可，如果有多条MX记录，请每条记录填写不同的优先级，注意优先级数字越小，表示优先级别越高。

    TTL ：解析缓存时间，以秒为单位。默认600表示该条记录将缓存的时候为10分钟，即你下次修改该记录，要过10分钟才能生效。TTL也不宜填写太小，如果填写太小，会导致IE访问该域名总要先做DNS解析，影响访问速度。一般对于动态域名解析的应用建议TTL设置在120至300之间，对于普通的应用建议设置成600至3600之间。

    解析组：智能解析标志，详见智能解析章节的说明。普通解析选择默认的“默认解析”即可。

  3. 上图点击“增加”按钮即可添加MX记录。DNS解析中多一条主机名为空的解析，表示winmydns的MX解析到mail.winmydns.com解析添加成功，如下图。

    点击上图中的“修改”按钮，可以直接修改该域名的MX指向的地址，如改成mail2.winmydns.com，如下图：

    修改MX地址之后，点该记录后面的“提交”按钮，即可修改winmydns的MX记录为mail2.winmydns.com。

  4. MX记录添加之后，一定要再添加mail.winmydns.com的A记录，指向到邮件服务器的IP地址才能生效。如下图：

    比如邮件服务器的IP地址是192.168.1.100,则A记录添加这后，该域名的完整的MX解析应该如下图：


NS记录解析

NS记录解析(一般用于把域名转接到其它的DNS服务器；即WinMyDNS中仅做NS解析，具体的A，MX，CNAME等解析在NS指向的其它DNS服务器中做)

  1. 点击功能菜单“DNS管理”菜单，找到您想要解析的域名，比如winmydns.com，点击该记录后面的“解析”链接，进入域名解析界面。 如下图:

  2. 在DNS解析表格的最下面一行，输入您想要转接的主机名，一般为空，所有的winmydns.com二级域名均转接到其它的DNS服务器解析；然后选择解析类型NS，参数值中填入NS指向的DNS服务器，如ns1.abc.com，点确定即可添加NS记录。如下图：

    主机名：一般为空，表示winmydns.com域名全部转接到其它的DNS服务器解析；如果填写abc，表示abc.winmydns.com的二级域名及其它的www.abc.winmydns.com的三级域名转接到其它的DNS服务器解析。

    类 型： 选择NS记录。

    参数值：要转接到的DNS服务器名称，如ns1.abc.com，注意不能直接写IP地址；如果要使该解析生效，必须ns1.abc.com的A记录已经指向到了其它的DNS服务器的IP地址，且该DNS服务器已经对winmydns.com的域名做了正确的解析。

    优先级：对于NS记录，优先级参数没有用，按默认的10即可。

    TTL ：解析缓存时间，以秒为单位。默认600表示该条记录将缓存的时候为10分钟，即你下次修改该记录，要过10分钟才能生效。TTL也不宜填写太小，如果填写太小，会导致IE访问该域名总要先做DNS解析，影响访问速度。一般对于动态域名解析的应用建议TTL设置在120至300之间，对于普通的应用建议设置成600至3600之间。

    解析组：智能解析标志，详见智能解析章节的说明。普通解析选择默认的“默认解析”即可。

  3. 上图点击“增加”按钮即可添加NS记录。DNS解析中多一条主机名为空的解析，表示winmydns的NS解析到ns1.abc.com解析添加成功，如下图。

    点击上图中的“修改”按钮，可以直接修改该域名的NS指向的地址，如改成ns1.123.com，如下图：

    修改NS地址之后，点该记录后面的“提交”按钮，即可修改winmydns.com的NS记录为ns1.123.com。


TXT记录解析

TXT记录解析(一般用于一些特殊的用途，如反垃圾邮件SPF技术等)

  1. 点击功能菜单“DNS管理”菜单，找到您想要解析的域名，比如winmydns.com，点击该记录后面的“解析”链接，进入域名解析界面。 如下图:

  2. 在DNS解析表格的最下面一行，输入您想要转接的主机名，一般为空，表示添加winmydns.com的TXT记录；然后选择解析类型TXT，参数值中填入特殊用途的文本内容，如反垃圾邮件SPF技术，可以填入“v=spf1 ip4:192.168.1.0/24 -all”，点确定即可添加TXT记录。如下图：

    主机名：一般为空，表示添加winmydns.com的TXT记录；如果填写abc，表示做abc.winmydns.com的TXT记录。

    类 型： 选择TXT记录。

    参数值：填写具体应用要求的文本内容。如反垃圾邮件SPF验证是填写格式如“v=spf1 ip4:192.168.1.0/24 -all”的文本。

    优先级：对于TXT记录，优先级参数没有用，按默认的10即可。

    TTL ：解析缓存时间，以秒为单位。默认600表示该条记录将缓存的时候为10分钟，即你下次修改该记录，要过10分钟才能生效。TTL也不宜填写太小，如果填写太小，会导致IE访问该域名总要先做DNS解析，影响访问速度。一般对于动态域名解析的应用建议TTL设置在120至300之间，对于普通的应用建议设置成600至3600之间。

    解析组：智能解析标志，详见智能解析章节的说明。普通解析选择默认的“默认解析”即可。

  3. 上图点击“增加”按钮即可添加TXT记录。DNS解析中多一条主机名为空的解析，表示winmydns.com的TXT解析"v=spf1 ip4:192.168.1.0/24 -all"添加成功，如下图。

    点击上图中的“修改”按钮，可以直接修改该域名的TXT指向的地址，如改成"v=spf1 ip4:192.168.2.0/24 -all"，如下图：

    修改TXT文本之后，点该记录后面的“提交”按钮，即可修改winmydns.com的TXT记录为"v=spf1 ip4:192.168.2.0/24 -all"。


IPV6记录解析

IPV6记录解析

  1. 点击功能菜单“DNS管理”菜单，找到您想要解析的域名，比如winmydns.com，点击该记录后面的“解析”链接，进入域名解析界面。 如下图:

  2. 在DNS解析表格的最下面一行，输入您想要解析的主机名，如www，表示添加www.winmydns.com的IPV6记录；然后选择解析类型AAAA，参数值中填入IPV6的IP地址，如“FD91:2ADD:715A:2111:DD48:AB34:D07C:3914"，点确定即可添加IPV6记录。如下图：

    主机名：输入不带域名本身的主机名，比如要解析www.winmydns.com，只要输入www即可；如果解析winmydns.com，主机名这里为空即可。

    类 型： 选择AAAA记录。

    参数值：填写您想要解析的IPV6的IP地址。。

    优先级：对于AAA记录，优先级参数没有用，按默认的10即可。

    TTL ：解析缓存时间，以秒为单位。默认600表示该条记录将缓存的时候为10分钟，即你下次修改该记录，要过10分钟才能生效。TTL也不宜填写太小，如果填写太小，会导致IE访问该域名总要先做DNS解析，影响访问速度。一般对于动态域名解析的应用建议TTL设置在120至300之间，对于普通的应用建议设置成600至3600之间。

    解析组：智能解析标志，详见智能解析章节的说明。普通解析选择默认的“默认解析”即可。

  3. 上图点击“增加”按钮即可添加AAAA记录。DNS解析中多一条主机名的www的解析，表示www.winmydns.com的IPV6解析到"FD91:2ADD:715A:2111:DD48:AB34:D07C:3914"添加成功，如下图。

    点击上图中的“修改”按钮，可以直接修改该域名的AAA指向的IP地址，如改成"1111:2222:715A:2111:DD48:AB34:D07C:3914"，如下图：

    修改TXT文本之后，点该记录后面的“提交”按钮，即可修改www.winmydns.com的AAA记录为"1111:2222:715A:2111:DD48:AB34:D07C:3914"。


反向解析

反向解析(注意：要做反向解析IP，必须先与上级IP分配管理机构，取得IP地址的DNS解析权后，在WinMyDNS中做反向解析才能生效，与域名修改DNS服务器成自已的类似)

  1. 点击功能菜单“DNS管理”菜单，新创建一个特殊的反向解析域名，如1.168.192.in-addr.arpa，在该域名下面可以做192.168.1.0-192.168.1.255的反向解析。 如下图:

  2. 点击“添加”按扭即可添加一个1.168.192.in-addr.arpa的反向解析域。如下图：

  3. 点击“解析”即可进入PTR反向解析，如下图。

    主机名：158，表示要做192.168.1.158这个IP的反向解析。

    类 型： 选择PTR记录。

    参数值：填写反向解析的域名，如mail.winmydns.com。

    优先级：对于PTR记录，优先级参数没有用，按默认的10即可。

    TTL ：解析缓存时间，以秒为单位。默认600表示该条记录将缓存的时候为10分钟，即你下次修改该记录，要过10分钟才能生效。

    解析组：智能解析标志组，详见智能解析章节的说明。普通解析选择默认的“默认解析”即可。

  4. 点击“增加”按钮，即可添加一条192.168.1.158指向到mail.winmydns.com的反向解析，如下图


URL转发解析

URL转发解析

  1. 点击功能菜单“DNS管理”菜单，找到您想要解析的域名，比如winmydns.com，点击该记录后面的“解析”链接，进入域名解析界面。 如下图:

  2. 在URL转发解析表格的最下面一行，输入您想要转发主机，如www；然后选择转发类型，转发地址中填写要转发到的网址，点确定即可添加URL转发记录。如下图：

    主 机 名：输入不带域名本身的主机名，比如要转发www.winmydns.com，只要输入www即可；如果转发winmydns.com，主机名这里为空即可。

    转发类型： 选择显性转发或隐性转发。

    转发地址：要转发到的网址，如www.winiis.com。

    解析组：智能解析标志组，详见智能解析章节的说明。普通解析选择默认的“默认解析”即可。

  3. 上图点击“增加”按钮即可URL转发记录。URL转发解析中多一条www的转发，表示www.winmydns.com转发到www.winiis.com添加成功，如下图。

    为了使URL转发生效，还应在上图的DNS解析中添加一条A记录，或者CNAME记录，指向到URL转发服务器的IP地址，比如URL转发服务器的IP地址是192.168.1.100,则添加后完整的一条www.winmydns.com转发的www.winiis.com的解析，如下图：


设置智能解析

设置智能解析

双线智能解析是本公司针对目前电信与网通互联互通的问题推出的一种DNS解决方案。具体实现的效果是：把同样的域名如www.winiis.com，网通的客户访问会返回一个指向网通服务器的IP地址， 电信的客户访问会指向一个电信服务器的IP地址。通过这种方式，尽量避免网通的客户去访问电信的网络， 以及电信的客户去访问网通的网络。

下面以www.winmydns域名为例，做如下的智能解析:

A) 电信的线路指向到192.168.1.1

B) 网通的线路指向到192.168.1.2

C) 非电信非网通的线路指向到192.168.1.3 (也可以指向到192.168.1.1,或192.168.1.2中的任意一个，表示非电信非网通的客户都解析到电信或网通的IP)

  1. 点击功能菜单“DNS管理”菜单，找到您想要解析的域名，比如winmydns.com，点击该记录后面的“解析”链接，进入域名解析界面。 如下图:

  2. 添加电信的解析，指向到192.168.1.1。解析添加方法与普通的A记录添加方法一样，唯一区别是解析组选择“电信解析”，如下图：

  3. 添加网通的解析，指向到192.168.1.2。解析添加方法与普通的A记录添加方法一样，唯一区别是解析组选择“网通解析”，如下图。

  4. 添加非电信非网通的解析，指向到192.168.1.3。解析添加方法与普通的A记录添加方法一样，唯一区别是解析组选择“默认解析”，如下图:

  5. 添加智能解析之后，该域名下有三条www的解析，但是解析组分别是电信、网通及默认解析，如下图:


设置宕机检测

设置宕机检测

宕机检测是指在智能解析案例中，如果系统检测到有某一个IP不通了，则域名不再往该IP上解析，而解析到其它可以正常使用的IP地址。

WinMyDNS系统宕机检测的方法是对在WinMYDNS服务器上，通过类似telnet的方法，检测某一个IP的某一个端口是否正常工作。如在WinMyDNS服务器上运行"telnet 192.168.1.1 80"检测出来是通的，则WinMyDNS系统认为192.168.1.1该IP是正常工作的，反之则认为该服务器已宕机。

下面以www.winmydns域名为例，假如下的智能解析:

A) 电信的线路指向到192.168.1.1

B) 网通的线路指向到192.168.1.2

C) 非电信非网通的线路指向到192.168.1.2

想要如实现如下的宕机检测：

A) 当电信的线路192.168.1.1正常，网通的线路192.168.1.2正常时，则电信的解析到192.168.1.1,网通的解析到192.168.1.2,非电信非网通的解析到192.168.1.2

B) 当电信的线路192.168.1.1宕机，网通的线路192.168.1.2正常时，则所有的解析都网通的解析，即192.168.1.2

C) 当电信的线路192.168.1.1正常，网通的线路192.168.1.2宕机时，则所有的解析都电信的解析，即192.168.1.1

按以下步骤设置，可以达到上述的宕机检测功能：

  1. 点击功能菜单“DNS管理”菜单，找到您想要解析的域名，比如winmydns.com，点击该记录后面的“解析”链接，进入域名解析界面。 如下图:

  2. 添加下面三条智能解析，如下图：

    注意：如果需要加快宕机检测的生效时间，也可以缩短每一条解析记录中的TTL值，一般建议设置在120至300之间，也不宜设置过短。否则会导致IE访问该域名总要先做DNS解析，影响访问速度

  3. 点击功能菜单“负载均衡”菜单，添加想要检测的IP及端口。 如下图:

    IP地址：填入需要做宕机检测的IP地址。

    检测端口：填入宕机检测时telnet检测的端口。

    权重：对于宕机检测功能没有用，按默认的100即可。

    分别添加192.168.1.1及192.168.1.2的宕机检测后如下图：


网络组管理

网络组管理(注意该功能一般不需要做任何设置，除非由熟悉路由的网络工程师配置或由本公司设置)

网络组允许自已定义类似电信、网通、教育网这样的解析组。在定义网络组之后，要求掌握该网络组的所有IP分配表，并将IP表设置到网络组中。

下面以创建一个"香港解析”网络组为例:

A) 在网络组中添加一个“香港解析”的网络组

B) 在IP分配表管理中，为“香港解析”解析网络组指定IP表。

C) 在智能解析中添加网络组为“香港解析”的记录。

按以下步骤添加新的网组：

  1. 点击功能菜单“网络组管理”菜单，在网络组管理最下面一行添加新的网络组。 如下图:

  2. 名称填入“香港解析”，描述填写“香港IP分配表”后，点击“添加”按钮即可添加一个网络组，如下图：

  3. 点击“香港解析”该网络组后面的“IP仇配表”即可为查看及管理该网络组的IP分配表。 如下图:

    点击添加IP分配记录，可为该网络组指定IP分配表，如下图：

    如要为其添加一条"59.188.0.0/16"的IP段，可以在逐条添加IP分配表中，填写IP地址59.188.0.0，子网掩码选择16，该IP段表示的IP范围是59.188.0.0-59.188.255.255。

    再点击“添加IP分配表”即可为其添加一个IP段。 (注:子网掩码表示的IP段，可以从这里下载子网计算工具来计算http://www.winiis.com/download/Subnet1_1.rar)

    如果要批量该网络组添加多条IP分配表，可以每行一条记录，IP地址与子掩码用空格分开的格式在“批量添加IP分配表”中添加，如下图：

    注意：对于自已定义的网络组，首先要通过IP收集工具或通过其它途径，收集齐全该网络组的所有IP分配表之后，才可以自已定义新网络组。

    各个网络组之间的IP段不应重叠，以免发生智能解析不准确的情况。

  4. 网络组添加完成后，可以在DNS解析那里看到，做各种解析时，后面的解析组均会多了一个“香港解析”的选择项，如下图：


设置负载均衡

设置负载均衡

负载均衡是指在智能解析案例中，如果同一个有解析组有两条以上的解析时，系统自动根据一定的概率调节两个IP的解析结果。以达到均衡两个IP的访问量的目的。

WinMyDNS系统宕机检测的方法是对在WinMYDNS服务器上，通过类似telnet的方法，检测某一个IP的某一个端口是否正常工作。如在WinMyDNS服务器上运行"telnet 192.168.1.1 80"检测出来是通的，则WinMyDNS系统认为192.168.1.1该IP是正常工作的，反之则认为该服务器已宕机。

下面以www.winmydns域名为例，假如下的智能解析:

A) 电信的线路指向到192.168.1.1，及192.168.1.100两条解析

B) 网通的线路指向到192.168.1.2

C) 非电信非网通的线路指向到192.168.1.2

想要如实现如下的负载均衡：

A) 当电信的线路192.168.1.1正常，电信的线路192.168.1.100正常时，则50%的电信客户解析到192.168.1.1,50%的电信客户解析到192.168.1.100

B) 当电信的线路192.168.1.1及电信的线路192.168.1.100有一个IP不正常时，则所有的电信解析解析到某一个正常的IP地址

C) 当电信的线路192.168.1.1及电信的线路192.168.1.100都不正常时，则所有的电信解析都指向到默认的非电信非网通的解析，即192.168.1.2

按以下步骤设置，可以达到上述的负载均衡功能：

  1. 点击功能菜单“DNS管理”菜单，找到您想要解析的域名，比如winmydns.com，点击该记录后面的“解析”链接，进入域名解析界面。 如下图:

  2. 添加下面四条智能解析(注意电信解析有两条192.168.1.1及192.168.1.100)，如下图：

    注意：如果需要加快负载均衡及宕机检测的生效时间，也可以缩短每一条解析记录中的TTL值，一般建议设置在120至300之间，也不宜设置过短。否则会导致IE访问该域名总要先做DNS解析，影响访问速度

  3. 点击功能菜单“负载均衡”菜单，添加想要负载均衡的IP，及宕机检测的端口。 如下图:

    IP地址：填入需要做宕机检测的IP地址。

    检测端口：填入宕机检测时telnet检测的端口。

    权重：控制该IP的访问量。某一个IP的被解析到的比例=W1/(W1+W2+....Wn)。比如该案例如果192.168.1.1的权重填10，192.168.1.100的权重填90，则192.168.1.1被解析到的比例是10/(10+90)=10%。说明192.168.1.1被解析到的概率只有10%。反之192.168.1.100被解析到的概率有90%。

    分别添加192.168.1.1及192.168.1.100的负载均衡后如下图：


会员管理

会员管理

本系统提供简易的会员管理功能，可以注册会员，管理员可以删作、修改、审核会员状态、设置会员权限、设置会员允许添加的域名数、设置会员允许添加的记录数。

  1. 点击功能菜单“会员管理”菜单，可以列出本系统中所有的会员。 如下图:

  2. 点击会员记录后面的“管理”链接，可以对该会员进行各种管理设置，如下图：


数据库

数据库简介

  1. WinMyDNS可以使用ACCESS及MSSQL数据库。；
  2. 两种数据库表的结构是一样的，都是由RR、SOA、NET、IPTABLE表组成。

建表脚本

if exists (select * from dbo.sysobjects where id = object_id(N'[dbo].[RR]') and OBJECTPROPERTY(id, N'IsUserTable') = 1)
drop table [dbo].[RR]
GO

if exists (select * from dbo.sysobjects where id = object_id(N'[dbo].[SOA]') and OBJECTPROPERTY(id, N'IsUserTable') = 1)
drop table [dbo].[SOA]
GO

if exists (select * from dbo.sysobjects where id = object_id(N'[dbo].[URL]') and OBJECTPROPERTY(id, N'IsUserTable') = 1)
drop table [dbo].[URL]
GO

if exists (select * from dbo.sysobjects where id = object_id(N'[dbo].[hostcheck]') and OBJECTPROPERTY(id, N'IsUserTable') = 1)
drop table [dbo].[hostcheck]
GO

if exists (select * from dbo.sysobjects where id = object_id(N'[dbo].[iptable]') and OBJECTPROPERTY(id, N'IsUserTable') = 1)
drop table [dbo].[iptable]
GO

if exists (select * from dbo.sysobjects where id = object_id(N'[dbo].[net]') and OBJECTPROPERTY(id, N'IsUserTable') = 1)
drop table [dbo].[net]
GO

if exists (select * from dbo.sysobjects where id = object_id(N'[dbo].[tmp_soa_192.168.1.158]') and OBJECTPROPERTY(id, N'IsUserTable') = 1)
drop table [dbo].[tmp_soa_192.168.1.158]
GO

if exists (select * from dbo.sysobjects where id = object_id(N'[dbo].[tmp_soa_192.168.137.1]') and OBJECTPROPERTY(id, N'IsUserTable') = 1)
drop table [dbo].[tmp_soa_192.168.137.1]
GO

if exists (select * from dbo.sysobjects where id = object_id(N'[dbo].[userlist]') and OBJECTPROPERTY(id, N'IsUserTable') = 1)
drop table [dbo].[userlist]
GO

CREATE TABLE [dbo].[RR] (
    [id] [int] IDENTITY (1, 1) NOT NULL ,
    [zone] [int] NOT NULL ,
    [name] [varchar] (64) COLLATE Chinese_PRC_CI_AS NOT NULL ,
    [type] [varchar] (50) COLLATE Chinese_PRC_CI_AS NOT NULL ,
    [data] [varchar] (128) COLLATE Chinese_PRC_CI_AS NOT NULL ,
    [aux] [int] NOT NULL ,
    [ttl] [int] NOT NULL ,
    [netid] [int] NOT NULL
) ON [PRIMARY]
GO

CREATE TABLE [dbo].[SOA] (
    [id] [int] IDENTITY (1, 1) NOT NULL ,
    [origin] [varchar] (255) COLLATE Chinese_PRC_CI_AS NOT NULL ,
    [ns] [varchar] (255) COLLATE Chinese_PRC_CI_AS NOT NULL ,
    [mbox] [varchar] (255) COLLATE Chinese_PRC_CI_AS NOT NULL ,
    [serial] [int] NOT NULL ,
    [refresh] [int] NOT NULL ,
    [retry] [int] NOT NULL ,
    [expire] [int] NOT NULL ,
    [minimum] [int] NOT NULL ,
    [ttl] [int] NOT NULL ,
    [serial_t] [int] NULL ,
    [username] [varchar] (50) COLLATE Chinese_PRC_CI_AS NULL ,
    [yn] [varchar] (5) COLLATE Chinese_PRC_CI_AS NULL ,
    [topdate] [datetime] NULL ,
    [enddate] [datetime] NULL
) ON [PRIMARY]
GO

CREATE TABLE [dbo].[URL] (
    [ID] [int] IDENTITY (1, 1) NOT NULL ,
    [domain] [varchar] (100) COLLATE Chinese_PRC_CI_AS NOT NULL ,
    [URL] [varchar] (250) COLLATE Chinese_PRC_CI_AS NOT NULL ,
    [URLtype] [varchar] (10) COLLATE Chinese_PRC_CI_AS NOT NULL ,
    [netid] [int] NOT NULL
) ON [PRIMARY]
GO

CREATE TABLE [dbo].[hostcheck] (
    [IP] [varchar] (50) COLLATE Chinese_PRC_CI_AS NOT NULL ,
    [port] [int] NOT NULL ,
    [weight] [int] NULL
) ON [PRIMARY]
GO

CREATE TABLE [dbo].[iptable] (
    [id] [int] IDENTITY (1, 1) NOT NULL ,
    [ip] [varchar] (15) COLLATE Chinese_PRC_CI_AS NOT NULL ,
    [mask] [int] NOT NULL ,
    [netid] [int] NOT NULL ,
    [remark] [text] COLLATE Chinese_PRC_CI_AS NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO

CREATE TABLE [dbo].[net] (
    [id] [int] IDENTITY (1, 1) NOT NULL ,
    [netname] [varchar] (50) COLLATE Chinese_PRC_CI_AS NOT NULL ,
    [remark] [varchar] (50) COLLATE Chinese_PRC_CI_AS NOT NULL
) ON [PRIMARY]
GO

CREATE TABLE [dbo].[userlist] (
    [ID] [int] IDENTITY (1, 1) NOT NULL ,
    [username] [varchar] (50) COLLATE Chinese_PRC_CI_AS NOT NULL ,
    [password] [varchar] (50) COLLATE Chinese_PRC_CI_AS NOT NULL ,
    [realname] [varchar] (50) COLLATE Chinese_PRC_CI_AS NOT NULL ,
    [tel] [varchar] (50) COLLATE Chinese_PRC_CI_AS NULL ,
    [address] [varchar] (50) COLLATE Chinese_PRC_CI_AS NULL ,
    [postcode] [varchar] (50) COLLATE Chinese_PRC_CI_AS NULL ,
    [email] [varchar] (50) COLLATE Chinese_PRC_CI_AS NULL ,
    [msn] [varchar] (50) COLLATE Chinese_PRC_CI_AS NULL ,
    [icq] [varchar] (50) COLLATE Chinese_PRC_CI_AS NULL ,
    [isadmin] [varchar] (50) COLLATE Chinese_PRC_CI_AS NULL ,
    [soanum] [int] NULL ,
    [rrnum] [int] NULL ,
    [verify] [varchar] (5) COLLATE Chinese_PRC_CI_AS NULL ,
    [regtime] [datetime] NULL
) ON [PRIMARY]
GO

SOA表

  1. SOA表是区域表，添加、修改、删除域名区域名即是对该表操作。
  2. SOA表字段说明:
    3. ID	整数	域名的唯一编号， RR表是的zone值与该值对应
origin	字符串	区域名
ns	字符串	域名服务器名称(WinMyDNS没用)
mbox	字符串	域名负责人邮箱(WinMyDNS没用)
serial	整数	版本编号,每次修改RR记录或修改SOA记录这后，都要把serial值加1，表示以修改
refresh	整数	刷新时间，辅DNS多少秒之后辅DNS检察解析是否已初修改(WinMyDNS没用)
retry	整数	重试时间，辅DNS如果刷新域名失败，多少秒之后重试（WinMyDNS没用）
expire	整数	过期时间，如果主DNS不可联系，辅DNS上多少秒之后认为记录已过期(WinMyDNS没用)
minimum,ttl	整数	有效期，如果RR中记录更短，返回RR记录中的TTL值。
yn		字符串	如果为0表示暂停,为1表示正常,状态为暂停时该区域名停止解析
topdate	日期	开始日期
enddate	日期	到期日期

RR表

  1. RR表是DNS解析记录表，所有的DNS解析记录均保存在该表中。
  2. RR表字段说明：
    3. ID	整数	RR表记录的ID号。
zone	整数	区域的ID号，跟SOA中的ID字段一致。
name	字符串	主机名，如:www
type	字符串	解析类型，如:A,MX,CNAME,NS等
data	字符串	解析数据，如：A记录填IP地址，MX，CNAME，NS记录填相对应的域名。
aux	整数	优先级，默认：10
ttl	整数	有效期。
netid	整数	解析网络组，与NET表中的ID值对应。如果为0表示默认解析.

NET表

  1. NET表是解析分组表，通过该表给浏览者定义来源网络分组，以便WinMyDNS根据分组来返回不同的解析结果。
  2. NET表字段说明：
    3. ID	整数	网络分组的ID号，与RR表中的netid字段对应。
netname	字符串	网络分组的名称。
remark	字符串	备注

IPTABLE表

  1. IPTABLE表是IP分配表。通过IPTABLE表来定义网络分组的具体的IP分配情况。
  2. IPTABLE表字段说明:
    ID	整数	IP分配表记录的ID号。
ip	字符串	IP地址。
mask	整数	子网掩码位数
netid	整数	网络组编号,与NET表中的ID值对应。
remark	字符串	备注

HOSTCHECK表

  1. HOSTCHECK表是宕机检测表。通过HOSTCHECK表来定义哪些机器需要做宕机检测。
  2. HOSTCHECK表字段说明:
    ID	整数	唯一标识。
ip	字符串	IP地址。
port	整数	被检测的TCP端口号
weight	整数	权重，被访问次数的比例

    3.


编程说明

编程简介

  1. 所有WinMyDNS的管理只要对ACCESS/MSSQL数据库直接进行操作即可生效。
  2. NET表及IPTABLE的修改需要重启WinMyDNS才能生效。
  3. SOA及RR表的修改，会在WinMyDNSAdmin.exe中设置的缓存时间设置的秒数至达时生效。
  4. 本文档以ASP为便介绍WinMyDNS的编程。

建立数据库链接

'ACCESS数据库可以如下建立数据链接：
WInMyDNSAccessFile="../DB/WinMyDNS.MDB"	'Access数据库文件名
connstr="DBQ="+Server.Mappath(WInMyDNSAccessFile)+";DefaultDir=;DRIVER={Microsoft Access Driver (*.mdb)};"
Set conn = Server.CreateObject("ADODB.Connection")
conn.Open connstr

'MSSQL数据库可以如下建立数据库链接：
WinMyDNSDbIP = "localhost"		'WINIIS_Server 数据库IP地址
WinMyDNSDbName="WinMyDNS"				'WINIIS_Server 数据库名
WinMyDNSDbUser="sa"					'WINIIS_Server 数据库用户名
WinMyDNSDbPass="linyang"			'WINIIS_Server 数据库密码

connstr="Provider=SQLOLEDB.1; Persist Security Info=True; Data Source="&WinMyDNSDbIP&"; Initial Catalog="&WinMyDNSDbName&"; User ID="&WinMyDNSDbUser&"; Password="&WinMyDNSDbPass
Set conn = Server.CreateObject("ADODB.Connection")
conn.Open connstr

网络组管理

  1. 定义网络组，在NET表中添加一条记录
    2. conn.execute("insert into net (netname,remark) values ('电信客户','电信客户群')")
'netname:网络组名称
'remark:备注
  2. 删除网络组，在NET表中删除一条记录
    3. conn.execute("delete from net where id=1 ")

IP分配表管理

  1. 添加一条IP分配记录即在IPTABLE表中添加一条记录。
    conn.execute("insert into iptable (ip,mask,netid) values ('218.2.0.0',16,1) ")
  2. 删除一条IP分配记录即在IPTABLE表中删除一条记录：
    3. conn.execute("delete from iptable where id=1 ")

区域管理

  1. 添加区域，即在SOA表中添加一条记录。
    insert into soa (origin,ns,mbox,serial,refresh,expire,minimum,ttl) values ('winiis.com','ns1.winiis.com','root.winiis.com',1,900,600,1800,3600,3600)
  2. 删除区域，即在SOA表中删除一条记录。
    3. conn.execute("delete from SOA where id=1 ")

解析管理

  1. 添加解析记录，即在RR表中添加一条记录。
    set rs=conn.execute("select ID from zone where origin='winiis.com' ")
'得到区域的ID号后，比如:ID=1,后插入RR记录：
insert into rr (zone,name,type,data,aux,ttl,netid) values (1,'www','192.168.1.1',10,3600,1)
'更新soa表的seial值，指明DNS解析已发生变化，便于DNS服务器重新加载记录:
update into soa set (serial=serial+1) where id=1
  2. 删除解析记录，即在RR表中删除一条记录。
    3. conn.execute("delete from RR where id=1 ")


数据移植

WinMyDNS与文本类DNS(如Windows自带的DNS服务)之间的数据互移

  1. 打开WinMyDNSAdmin.exe，打开“数据移植“页面，如下图:

    上面一个框是从Window DNS移植到WinMyDNS系统；下面一个框相反，是从WinMyDNS系统移植到Window DNS。两种移植之后均可立即使用：

  2. 从window DNS移植到WinMyDNS系统。

    把win2000系统下的C:\winnt\system32\dns目录，或window2003下的c:\windows\system32\dns目录下的所有后缀名为.dns的文件考到WinMyDNS的DnsFile目录下。然后点击“从WIN DNS文件导入WinMyDNS系统”，就会把这些文件里包括所有DNS信息插入到WinMyDNS系统的数据库中，重启WinMyDNS服务，即可生效。

    同时移植程序会在当前目录下生成两个文件，一个是dns.sql；一个是dns.sql_Err.txt。dns.sql是标准的sql语句，直接运行该SQL语句也可以把DNS区域插入到本系统。dns.sql_Err.txt是错误信息，如果移植过程序中有出现错误记录会在该文件中记录，以便管理员查找原因。

  3. 从WinMyDNS系统移植到Window DNS系统。

点击“WinMyDNS系统的DNS记录转成WIN DNS文件，就会在DnsFile目录下生成windows DNS系统所需要的所有DNS区域文件，以及boot文件。

把这些文件本部考到 win2000系统下的C:\winnt\system32\dns目录，或window2003下的c:\windows\system32\dns目录下，重启windows DNS服务即可生效。


WinMyDNS常见问题

WinMyDNS

常见问题

常见问题

  • 一、什么是双线智能DNS解析？
  • 二、双线智能DNS解析的用途？
  • 三、为什么要选用WinMyDNS而不是Bind 9或MyDNS？
  • 四、WinMyDNS的性能如何？如何提高WinMyDNS的性能？
  • 五、如何测试WinMyDNS工作是否正常？
  • 六、如何使用winmydns搭建DNS服务器？
  • ......

问题解答

  • 一、什么是双线智能DNS解析？

    双线智能解析是本公司针对目前电信与网通互联互通的问题推出的一种DNS解决方案。具体实现的效果是：把同样的域名如www.winiis.com，网通的客户访问会返回一个指向网通服务器的IP地址， 电信的客户访问会指向一个电信服务器的IP地址。通过这种方式，尽量避免网通的客户去访问电信的网络， 以及电信的客户去访问网通的网络

  • 二、双线智能DNS解析的用途？

    1、双线路机房：
    服务本身有两个IP，一个电信IP，一个网通IP。

    2、镜象网站；
    在网通及电信的机房放置多个相同的镜象站点， 让不同的地方客户访问不同的站点。

    3、负载均衡：

    对于流量比较大的网站，可以通过该功能把流量分配到几台不同的服务器上，以提高网站的运行速度。

    4、个性化站点服务：

    比如通过IP表的重新定义， 让国外的客户自动访问英文版的网站； 让国内的客户自动访问中文版的网站。

  • 三、为什么选用WinMyDNS而不是bind9或MyDNS？

    1.平台不同。WinMyDNS是基于目前全球使用广泛、最容易使用Windows平台，而Bind9及MyDNS都是基于界面不友好的Unix平台。

    2.WinMyDNS把DNS数据保存在ACCESS/或MSSQL数据库中，直接修改数据库记录即可直接生效。

    3.WinMyDNS支持双线智能解析。可以自由定义网络定，IP分配表等。

    4.Bind9把配置信息保存文本文件，只能手工修改，且修改文件需要重启DNS服务才能生效，不适用DNS自助解析。WinMyDNS不用。

    5.MyDNS不支持双线智能解析。

    6.WinMyDNS是经常专业高级技术人员严格研究及测试的成熟产品。可以支持几十万域名的解析。性能优于Bind9及MyDNS。

  • 四、WinMyDNS的性能如何？如何提高WinMyDNS的性能？

    1.WinMyDNS对性能采用特殊的优化技术，可以支持几十万个域名的解析，经测试，一万至十万之间的域名量，WinMyDNS的CPU使用率一般在0-5%之间，且不会随域名量的增加而线性增加

    2.采用MSSQL数据库以提高速度

    3.在WinMyDNSAdmin.exe配置中，把“记录文本日志去掉”，以提高速度。

    3.在WinMyDNSAdmin.exe配置中，把“缓存时间”设置稍微长一点，减少数据库读取的频率，以提高速度， 这个时间是DNS解析在WinMyDNS里的生效时间，设置长了生效时间也会相对的变长。

  • 五、如何测试WinMyDNS工作是否正常？

    1.使用netstat命令查看DNS是否在UDP的53端口工作
    使用netstat命令检查53端口是否打开：开始->运行->cmd.exe然后输入netstat -an -p udp如下：

    C:\Documents and Settings\Administrator>netstat -an -p udp

Active Connections

  Proto  Local Address          Foreign Address        State
  UDP    0.0.0.0:445            *:*
  UDP    0.0.0.0:1434           *:*
  UDP    0.0.0.0:3456           *:*
  UDP    127.0.0.1:1046         *:*
  UDP    127.0.0.1:1047         *:*
  UDP    127.0.0.1:1082         *:*
  UDP    192.168.1.158:9        *:*
  UDP    192.168.1.158:53       *:*
  UDP    192.168.1.158:137      *:*
  UDP    192.168.1.158:138      *:*
  UDP    192.168.1.158:500      *:*
  UDP    192.168.1.158:4500     *:*
  UDP    192.168.1.158:6163     *:*
  UDP    192.168.21.1:53        *:*
  UDP    192.168.21.1:137       *:*
  UDP    192.168.21.1:138       *:*
  UDP    192.168.21.1:500       *:*
  UDP    192.168.21.1:4500      *:*
  UDP    192.168.21.1:30653     *:*
  UDP    192.168.137.1:53       *:*
  UDP    192.168.137.1:137      *:*
  UDP    192.168.137.1:138      *:*
  UDP    192.168.137.1:500      *:*
  UDP    192.168.137.1:4500     *:*
  UDP    192.168.137.1:64677    *:*

C:\Documents and Settings\Administrator>
    如果winmydns工作正常。会在相应的IP有一条53的进示。如上面的记录： UDP 192.168.1.158:53 *:*。如果没有53端口被打开。请在WinMyDNSAdmin.exe里启动一下winmydns服务。

    2.使用nslookup命令测试DNS解析是否正常
    先确认域名的DNS器是否为您公司的DNS服务器。国际域名请到http://www.internic.com/whois.html查询。国内域名请到www.cnnic.cn查询。
    使用nslookup命令检查您的DNS服务器是否解析正常：开始->运行->cmd.exe然后输入nslookup如下：

    C:\Documents and Settings\Administrator>nslookup
Default Server:  dns.fz.fj.cn
Address:  202.101.98.55

> server 192.168.1.158
Default Server:  [192.168.1.158]
Address:  192.168.1.158

> www.abc.com
Server:  [192.168.1.158]
Address:  192.168.1.158

Name:    www.abc.com
Address:  210.72.225.179

> set type=mx
> mail.abc.com
Server:  [192.168.1.158]
Address:  192.168.1.158

DNS request timed out.
    timeout was 2 seconds.
DNS request timed out.
    timeout was 2 seconds.
*** Request to 192.168.1.158 timed-out
>
    使用server 命令nslookup指向到您的DNS服务器进行查询。
    使用set type=MX 或set type=A等命令查询指示查询的DNS类型。
    直接输入www.abc.com等域名查询DNS解析结果。如果是A记录会出来IP地址。如果MX记录，会出来邮箱交换域名。

  • 六、如何用winmydns搭建DNS服务器？

    1、你必须有一个属于您自已的域名。比如：abc.com。没有域名的必须先注册一个域名。

    2、在国际域名中心注册一个DNS域名，以使你的DNS服务器在全球有效。
    A、在域名注册商（如新网，新网互联）的域名控制面板里一个“注册本域名下的DNS”的功能。
    B、点击进去添加两个DNS，如ns1.abc.com及ns2.abc.com，IP地址填写你的安装winmydns的服务器IP地址。如果没有两台机器或两个固定IP，ns2可以随便写一个IP。
    C、在http://www.internic.com/whois.html页面填入你的DNS域名，如ns1.abc.com，选择"Nameserver"，点submit看看你注册的DNS有没有生效。

    3、新注册域名时，在DNS服务器框里填写你自已的ns1.abc.com及ns2.abc.com，不要使用域名注册商默认的。如果是已注册的域名，请修改域名的DNS服务器为ns1.abc.com及ns2.abc.com。

    4、参考winmydns的安装方法，正常安装winmydns,并在WEB管理做域名解析。

  • ......

福州慧林网络科技有限公司 研发部


WinMyDNS公司简介

WinMyDNS

公司简介

公司简介

     福州慧林网络科技有限公司是一家位于福建省省会福州的致力于提供IDC业务管理软件的运营商。公司拥有一支由业内资深技术人才、优秀的管理、服务人才组成的运营团队，有着超过5年的IDC业务管理软件从业经验，成功开发并推广砺青虚拟主机管理系统、WinIIS服务器集中管理系统、WinMyDNS双线智能DNS解析系统、IIS监控系统等一系列IDC业务相关软件产品。其中砺青虚拟主机管理系统已申报国家知识产权保护，成功获得了国家版权证书。

     慧林科技与河北省网通、河南省网通、北京新网互联、南京中国数据、上海中国互联等著名的虚拟主机提供商及部分电信省市级企业有着良好的合作关系。本公司提供的虚拟主机管理系统已成功的在河北省网通、新网互联、中国数据、中国互联良好运行。稳定性、安全性、键状性、先进性得到了客户的一致好评。

     作为国内IDC管理软件行业领先的服务商，慧林科技奉行"以智慧立足于创新之林"的企业宗旨，不断追求技术领先、服务领先、模式领先、业绩领先的发展目标，率先在业内推出.NET虚拟主机管理系统，首创的业务系统、主控端、受控端三层软件体系统结构，采用标谁的XML报文通讯协议，为国内的虚拟主机行业做出了突出的贡献。

     本年度公司在全国范围内首推的WinMyDNS双线智能DNS解析系统，更是为当前的电信网通互联互通及负载均衡的问题提供了先进的DNS层面上的解决方案。该方案不必增加任何硬件设备，即可客户就近访问你的让双线路机房及境象站点。智能DNS概念的提出更是具体划时代的意思。

     诚实守信、勇于创新是慧林科技的服务理念，为此慧林科技又率先在业内推出了电信级企业版软件，提供了电信企业独特的营业厅业务受理流程。这一流程的提出，为国内的电信企业充分利用营业网点的优势开展IDC业务提供了可能。

慧林科技凭借其一流的运营管理团队，强大的创新精神、技术、电信资源优势，吸引了众多知名厂商和合作伙伴，结成了广泛的业务联盟。其不断推出的IDC业务管理软件已成为企业持续高速增长的核心动力。成功来自团队，超越客户满意。慧林科技正在全力打造IDC业务管理软件领域的第一品牌。

慧林科技联系方式：

电 话：0591-87202125
传 真：0591-87642292
Email：info@lqwl.com
邮 编：350002
地 址：福建省福州市工业路403号中茵花城6#206。

网 址：www.winmydns.com

www.winiis.com